Vrooooooooooooooom!
User avatar
By Automotive Gaming
Rank: Learner Driver
#22138
Hmm, it's the first time I heard about a similar problem, I guess you already tried to change the texture quality via "WR2_Setup". :think:
I also assume you already have the latest Patch (1.4.3) and compatibily mode set to Windows XP (Service Pack 2). These are usually some things which can fix the game issues.
Last edited by Automotive Gaming on Mon Jul 28, 2014 10:30 pm, edited 1 time in total.
By sw3gameboy
Rank: Apprentice
#22145
Automotive Gaming wrote:Hmm, it's the first time I heard about a similar problem, I guess you already tried to change the texture quality via "WR2_Setup". :think:
I also assume you already have the latest Patch (1.6.6) and compatibily mode set to Windows XP (Service Pack 2). These are usually some things which can fix the game issues.
I haven't tested the patch thing :geek: altrough when i try to find it then it's either a MB World Racing patch or it's a "harmful website" (according to Avast) :(
By sw3gameboy
Rank: Apprentice
#22177
Automotive Gaming wrote:My fault, lol, i confused MBWR patch with WR2 patch, and yes you need the 1.4.3 Patch, just in case you miss it, here it is: http://www.mediafire.com/download/9pube ... +1.4.3.rar" onclick="window.open(this.href);return false;
my copy of the game installs it with the 1.4.3 patch already, so that isn't the problem :geek: I do however consider if the problem is because my processor have dual cores or not :think:
By sw3gameboy
Rank: Apprentice
#26345
nice shots :shock: wish I could play the game properly on my computer...

PS: I haven't checked around games.reveur.de yet regarding this weird glitch :?
They Are Billions

They Are Billions This game is doing my head […]

PC Water Cooling

Nice, long time in the making, but hope you get it[…]

Formula1 Talk

Yes, F-E starts to get mature quickly now. Lots of[…]

Project CARS 2 DLC

Although the Porsche Legends Pack hasn't been full[…]